FORUMCategory: BioinformaticsSTAR input error
nibeh Staff asked 1 year ago



  • I recently tried to run the STAR aligner on four fastq files, and received the following error: “fatal INPUT ERROR: number of input files for mate1: 4 is not equal to that for mate2: 1. Make sure that the number of files in –readFilesIn is the same for both mates”
    What does this mean? My command was:

    STAR –genomeDir /User/me/STAR_hg19 –readFilesCommand gunzip -c –readFilesIn Sample1_L001_R1_001.fastq.gz, Sample2_L001_R1_001.fastq.gz, Sample3_L001_R2_001.fastq.gz, Sample4_L001_R2_001.fastq.gz –outFileNamePrefix Sample_ –runThreadN 14 –outBAMsortingThreadN 4 –outSAMstrandField intronMotif –outFilterIntronMotifs RemoveNoncanonicalUnannotated –outSAMattributes All –outSAMtype BAM SortedByCoordinate

    1 Answers
    jrosner Staff answered 1 year ago



  • Hi nibeh,
    you’re command is mostly correct, but i believe the problem has to do with the way you’ve specified the –readFilesIn option.
    that is, the groups of paired-end mates needs to be separated with spaces like so:


    –-readFilesIn Sample1_L001_R1_001.fastq.gz,Sample2_L001_R1_001.fastq.gz Sample3_L001_R2_001.fastq.gz,Sample4_L001_R2_001.fastq.gz

    and just to make sure, you should be using double dash "--" instead of single dash "-" for the command options.

    jrosner Staff replied 1 year ago

    might be hard to see because of the line wrap, but there is a space between the first fastq pair and the second fastq pair